Another fine Beta (2) release of CADuntu

Hello!

I just released a other Beta release of CADuntu. More issues have been solved and CADuntu keeps looking better each day, I am very happy! Also I am happy to see that the community is picking CADuntu up because there are now many blogs (here, here, here and here……. and here ) that wrote an article about it, thanks to everybody! This makes it even more worth to keep working towards the release candidates and final releases.

What has been improved in CADuntu?

  • Fixed 64 bit builds
  • Fixed hatches not showing up (Yan Zagorskih)
  • Better dialog size handing for some dialogs
  • No more toolbar clutter on the left hand side (Reported by Sliptronic)
  • Improved installer for XP, Vista and Windows Seven
  • Improved status bar message handling

I already got some reports that CADuntu didn’t work on a 64Bits OS like here so I also fixed and tested this on a Debian 64Bits, this would make all 64Bits users very happy. I got in a patch from Yan thanks! that found a bug with hatches, that where not shown up correctly. Also there was a bug where during operations the screen wasn’t updated properly. For example when you selected a line in trim mode, the line would not show up as selected.

With 266 downloads (as of today) am am very happy with the result and how this was picked up you can download a new version at SF overhere: https://sourceforge.net/projects/caduntu/files/

Ries van Twisk

9 thoughts on “Another fine Beta (2) release of CADuntu

    • Andrès,

      seems like a lot of architects use Linux nowdays :)
      I think a good start would be when I make a blogpost on how to compile on a Debian or Ubuntu machine. This would be a good start to help out.

      Ries

  1. Hello!

    Ubuntu Install failure. All required libraries installed.

    1- in terminal paste “svn co https://caduntu.svn.sourceforge.net/svnroot/caduntu caduntu”
    2- “cd caduntu”, next “cd trunk”
    3- type “qmake-qt4″, next type “make”.

    i get the following error:

    scripts/postprocess-unix.sh
    error: Cannot load ‘custom.pro': No such file or directory
    sed: -e expression #1, char 1: unknown command: `”‘
    grep: [0-9]*”: No such file or directory
    svn: Write error: Broken pipe
    sed: -e expression #1, char 1: unknown command: `”‘
    grep: [0-9]*”: No such file or directory
    svn: Write error: Broken pipe

    • Helder,

      I have seen that error before on Ubuntu ( I test on Debian),
      I think that means that you have qt3 installed and wmake is confused somehow.

      I did my own tests today with compiling on Caduntu 10, and that worked without problems.

      Ries

  2. Just built in on Gentoo. I must say, I’m impressed that such a young fork / port built on the first try.

    I did notice that the dxflib and fparser have to get built on their own. Perhaps their build processes can be incorporated into the qmake generated makefile?

    I really hope this project gets traction. Thanks for your efforts.

    • Fish,

      the dxflib and fparser don’t need to be build anymore on there own, I just didn’t have the time yet to clean that up from the original QCad download.
      But in reality all it takes is to run qmake, make.

      Ries

Leave a Reply to FishB8 Cancel reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>